unity Android端末のビルド

結局、なんだかんだ3日目で

やっとビルドできました。

 

プログラミングするよりも疲れますね…。

 

始めのうちはエラーばかりで

まったく見込みがない状態でしたが

調べていくうちに少しずつ前進。

内容としては、やはり

最新のバージョンに対応していない

…ということです。

 

調べるとエラー対策はたくさんあります。

…とりあえずやれるだけやってみるしかないですが。

その中でも重要そうなものをピックアップしておきます。

 

●スマホを開発者モードにしておく。デバッグを有効にする。

(端末で検索かければ出てきます)

 

●android.batからSDKmanagerを起動、

そこからスマホに対応したバージョンを入れておく。

 

●jdkのバージョン。最新のものは対応していない?らしい。

 

●jdkなどのPATHに日本語が含まれていないか

 

●USBコードが充電用の場合もある

…ざっと、こんなところでしょうか。

 

意外と落とし穴になっているのが

スマホのバージョンに対応したSDKが入っているか

これが重要だと思います。

 

現に私のスマホはandroid7.1(p9lite)です。

それに対応したSDKがないとビルドできないはず…なので。

 

先日の記事で、

書き込みまでいくその手前でエラーが出てた原因は

「これか…?」と思っています。

 

できるようになった今でも本当にこれなのか?と

首をかしげている状態ですけどね(汗)

 

とにかくビルドできてよかった…。

モヤモヤがすっきりして安心して勉強に集中できます。

 

 

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です